Авторизация
Исполнитель с фиксированным набором команд
Информатика 9 класс | Автор: пр | ID: 7158 | Дата: 22.1.2016
0 0
Помещать страницу в закладки могут только зарегистрированные пользователи
Зарегистрироваться
Вопрос № 1

Чертёжнику был дан для исполнения следующий алгоритм:
Повтори 3 раз
Сместиться на (–2, –3) Сместиться на (3, 4)
конец
Сместиться на (–4, –2)
Какую команду надо выполнить Чертёжнику, чтобы вернуться в исходную точку, из которой он начал движение?

Сместиться на (1, –1)
Сместиться на (–3, –1)
Сместиться на (–3, –3)
Сместиться на (–1, 1)
Вопрос № 2

Чертёжнику был дан для исполнения следующий алгоритм:
Повтори 2 раз
Сместиться на (–3, –4) Сместиться на (3, 3) Сместиться на (1, –2)
Конец
Какую единственную команду надо выполнить Чертёжнику, чтобы вернуться в исходную точку, из которой он начал движение?

Сместиться на (2, –6)
Сместиться на (–6, 2)
Сместиться на (6, –2)
Сместиться на (–2, 6)
Вопрос № 3

Черепашке был дан для исполнения следующий алгоритм:
Повтори 12 [Направо 45 Вперёд 20 Направо 45].
Какая фигура появится на экране?

незамкнутая ломаная линия
правильный двенадцатиугольник
квадрат
правильный восьмиугольник
Вопрос № 4

Чертёжнику был дан для исполнения следующий алгоритм:
Сместиться на (–3, 1)
Повтори 2 раз
Сместиться на (1, 1) Сместиться на (-3, 2) Сместиться на (0,-4)
Конец
Какую единственную команду надо выполнить Чертёжнику, чтобы вернуться в исходную точку, из которой он начал движение?

Сместиться на (4, 2)
Сместиться на (–4, –2)
Сместиться на (7, 1)
Сместиться на (–7, –1)
Вопрос № 5

Черепашке был дан для исполнения следующий алгоритм:
Повтори 6 [Вперёд 5 Направо 30]
Какая фигура появится на экране?

незамкнутая ломаная линия
правильный треугольник
правильный пятиугольник
правильный шестиугольник
Вопрос № 6

При выполнении какого из перечисленных ниже алгоритмов на экране появился правильный шестиугольник?

Повтори 6 [Вперёд 100 Направо 90]
Повтори 6 [Вперёд 100 Направо 9]
Повтори 6 [Вперёд 100 Направо 60 Направо 60]
Повтори 6 [Вперёд 100 Направо 20 Направо 40]
Вопрос № 7

При выполнении какого из перечисленных ниже алгоритмов на экране появился правильный треугольник?

Повтори 3 [Вперёд 50 Направо 20 Направо 25]
Повтори 3 [Вперёд 50 Направо 100 Направо 20]
Повтори 6 [Вперёд 50 Направо 10 Направо 20]
Повтори 6 [Вперёд 50 Направо 20 Направо 40]
Вопрос № 8

Чертёжнику был дан для исполнения следующий алгоритм:
Сместиться на (2, –7)
Повтори 6 раз
Сместиться на (0, 1) Сместиться на (–1, 1) Сместиться на (–2, 2)
Конец
Какую команду надо выполнить Чертёжнику, чтобы вернуться в исходную точку, из которой он начал движение?

Сместиться на (–18, 24)
Сместиться на (18, –24)
Сместиться на (16, –17)
Сместиться на (–16, 17)
Вопрос № 9

Чертёжнику был дан для исполнения следующий алгоритм:
Сместиться на (1, 3)
Повтори 4 раз
Сместиться на (0, 2) Сместиться на (3, 1) Сместиться на (–4, –4)
Конец
Какую команду надо выполнить Чертёжнику, чтобы вернуться в исходную точку, из которой он начал движение?

Сместиться на (–3, –1)
Сместиться на (3, 1)
Сместиться на (–4, –4)
Сместиться на (4, 4)
Вопрос № 10

Чертёжнику был дан для исполнения следующий алгоритм:
Сместиться на (2, 6)
Повтори 2 раз
Сместиться на (2, 1) Сместиться на (–5, 4) Сместиться на (1,–4)
Конец
Какую команду надо выполнить Чертёжнику, чтобы вернуться в исходную точку, из которой он начал движение?

Сместиться на (4, –2)
Сместиться на (–4, 2)
Сместиться на (2, –8)
Сместиться на (–2, 8)
Вопрос № 11

Чертёжнику был дан для исполнения следующий алгоритм:
Сместиться на (–3, 1)
Повтори 2 раз
Сместиться на (1, 1) Сместиться на (?3, 2) Сместиться на (0, ?4)
Конец
Какую единственную команду надо выполнить Чертёжнику, чтобы вернуться в исходную точку, из которой он начал движение?

Сместиться на (–7,–1)
Сместиться на (7, 1)
Сместиться на (–4,–2)
Сместиться на (4, 2)
Вопрос № 12

Чертёжнику был дан для исполнения следующий алгоритм:
Повтори 3 paз
Сместиться на (-2, -3) Сместиться на (3, 2) Сместиться на (-4,0)
Конец
На какую одну команду можно заменить этот алгоритм, чтобы Чертёжник оказался в той же точке, что и после выполнения алгоритма?

Сместиться на (-9, -3)
Сместиться на (-3, 9)
Сместиться на (-3, -1)
Сместиться на (9, 3)
Вопрос № 13

Черепашке был дан для исполнения следующий алгоритм: Повтори 360 [Вперёд 30 Направо 60]. Какая фигура появится на экране?

правильный 360-угольник
правильный треугольник
правильный шестиугольник
незамкнутая ломаная линия
Вопрос № 14

Чертёжнику был дан для исполнения следующий алгоритм:
Сместиться на (-5, 2) Повтори 5 раз
Сместиться на (2, 0) Сместиться на (-3, -3) Сместиться на (-1, 0) конец
На какую команду можно заменить этот алгоритм?

Сместиться на (-10, -15)
Сместиться на (15, 13)
Сместиться на (10, 15)
Сместиться на (-15, -13)
Вопрос № 15

Чертёжнику был дан для исполнения следующий алгоритм:
Повтори 5 paз
Сместиться на (0, 1) Сместиться на (-2, 3) Сместиться на (4, -5) Конец
Каковы координаты точки, с которой Чертёжник начинал движение, если в конце он оказался в точке с координатами (-1, -1)?

(-11, 4)
(4, -11)
(8, 22)
(22, 8)
Вопрос № 16

Чертёжнику был дан для исполнения следующий алгоритм:
Повтори 7 paз
Сместиться на (-1, 2) Сместиться на (-2, 2) Сместиться на (4, -5) Конец
Каковы координаты точки, с которой Чертёжник начинал движение, если в конце он оказался в точке с координатами (1, 1)?

(6, 8)
(-6, 8)
(8, -6)
(8, 6)
Вопрос № 17

Чертёжнику был дан для исполнения следующий алгоритм:
Повтори 3 paз
Сместиться на (-2, -1) Сместиться на (3, 2) Сместиться на (2,1) Конец
На какую одну команду можно заменить этот алгоритм, чтобы Чертёжник оказался в той же точке, что и после выполнения алгоритма?

Сместиться на (-9, -6)
Сместиться на (6, 9)
Сместиться на (-6, -9)
Сместиться на (9, 6)
Вопрос № 18

Чертёжнику был дан для исполнения следующий алгоритм:
Повтори 2 paз
Команда1 Сместиться на (1, 3) Сместиться на (1, -2) Конец
Сместиться на (2, 6)
После выполнения этого алгоритма Чертёжник вернулся в исходную точку. Какую команду надо поставить вместо команды Команда1?

Сместиться на (-6, -8)
Сместиться на (3, 4)
Сместиться на (-4, -7)
Сместиться на (-3, -4)
Вопрос № 19

Чертёжнику был дан для исполнения следующий алгоритм:
Повтори 4 paз
Команда1 Сместиться на (1, 3) Сместиться на (1, -2) Конец
Сместиться на (-4, -12)
После выполнения этого алгоритма Чертёжник вернулся в исходную точку. Какую команду надо поставить вместо команды Команда1?

Сместиться на (1,-2)
Сместиться на (12, 4)
Сместиться на (2, 11)
Сместиться на (-1, 2)
Вопрос № 20

Чертёжнику был дан для исполнения следующий алгоритм:
Повтори 4 paз
Команда1 Сместиться на (3, 2) Сместиться на (2, 1) Конец
Сместиться на (-12, -8)
После выполнения этого алгоритма Чертёжник вернулся в исходную точку. Какую команду надо поставить вместо команды Команда1?

Сместиться на (-8, -4)
Сместиться на (-2, -1)
Сместиться на (7, 5)
Сместиться на (2, 1)
Скачать тест
можно через
сек.
Комментарии (0)

    Вы должны авторизоваться, чтобы оставлять комментарии.